Back
Downtime

We are currently experiencing server issues

Started 5 Mar at 11:43am CET, resolved 5 Mar at 11:48am CET.

App
Resolved

We have identified and fixed the issue. All services operational.

Posted 5 Mar at 11:48am CET.
Created

we are actively investigating the issue and work on an immediate fix.

Posted 5 Mar at 11:43am CET.